CVE-2018-25033

NameCVE-2018-25033
DescriptionADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1010770

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
admesh (PTS)stretch0.98.2-3vulnerable
buster0.98.3-3vulnerable
bookworm, sid, bullseye0.98.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
admeshsource(unstable)(unfixed)1010770

Notes

[bullseye] - admesh <no-dsa> (Minor issue; can be fixed via point release)
[buster] - admesh <no-dsa> (Minor issue; can be fixed via point release)
https://github.com/admesh/admesh/issues/28
https://github.com/admesh/admesh/commit/e84d8353f1347e1f26f0a95770d92ba14e6ede38

Search for package or bug name: Reporting problems