CVE-2018-2562

NameCVE-2018-2562
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server : Partition). Supported versions that are affected are 5.5.58 and prior, 5.6.38 and prior and 5.7.19 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server as well as unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.0 Base Score 7.1 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1250-1, DSA-4091-1
NVD severityhigh (attack range: remote)
Debian Bugs898444

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie (security), jessie10.0.32-0+deb8u1vulnerable
mariadb-10.1 (PTS)stretch (security), stretch10.1.26-0+deb9u1vulnerable
buster, sid1:10.1.29-6vulnerable
mysql-5.5 (PTS)jessie (security), jessie5.5.60-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)high
mariadb-10.1source(unstable)(unfixed)high898444
mysql-5.5source(unstable)(unfixed)high
mysql-5.5sourcejessie5.5.59-0+deb8u1highDSA-4091-1
mysql-5.5sourcewheezy5.5.59-0+deb7u1highDLA-1250-1
mysql-5.7source(unstable)5.7.20-1high

Notes

Fixed in MariaDB 10.0.34, 10.1.31
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html#AppendixMSQL

Search for package or bug name: Reporting problems