CVE-2018-2585

NameCVE-2018-2585
DescriptionVulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Net). Supported versions that are affected are 6.9.9 and prior and 6.10.4 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Connectors. CVSS 3.0 Base Score 7.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs887751

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-connector-net (PTS)jessie6.4.3-2vulnerable
sid, stretch6.4.3-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-connector-netsource(unstable)(unfixed)high887751

Notes

[stretch] - mysql-connector-net <no-dsa> (Minor issue)
[jessie] - mysql-connector-net <no-dsa> (Minor issue)
[wheezy] - mysql-connector-net <no-dsa> (Minor issue)
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html#AppendixMSQL

Search for package or bug name: Reporting problems