DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Security: Encryption). Supported versions that are affected are 5.5.60 and prior, 5.6.40 and prior and 5.7.22 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Server accessible data. CVSS 3.0 Base Score 3.1 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1407-1, DLA-1566-1, DSA-4341-1
NVD severitylow
Debian Bugs904121

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.1 (PTS)stretch10.1.45-0+deb9u1fixed
stretch (security)10.1.47-0+deb9u1fixed
mysql-5.7 (PTS)sid5.7.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[wheezy] - mysql-5.5 <postponed> (Wait for next upstream security/bugfix release)
Result from an incomplete fix for CVE-2015-3152 and related CVE for
Oracle products.
For MariaDB: if one connects to the remote server using the embedded library
(libmysqld), then SSL is not enforced.
Fixed in MariaDB: 5.5.60, 10.0.35, 10.1.33, 10.2.15, and 10.3.7
For Oracle:
fixed in 5.5.61, 5.6.41, 5.7.23
Strictly speaking though the CVE would be only for Oracle MySQL, for practical
reasons still tracking as well MariaDB here.

Search for package or bug name: Reporting problems