CVE-2018-2767

NameCVE-2018-2767
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Security: Encryption). Supported versions that are affected are 5.5.60 and prior, 5.6.40 and prior and 5.7.22 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Server accessible data. CVSS 3.0 Base Score 3.1 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1407-1, DLA-1566-1, DSA-4341-1
NVD severitylow (attack range: remote)
Debian Bugs904121

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.32-0+deb8u1vulnerable
jessie (security)10.0.37-0+deb8u1fixed
mariadb-10.1 (PTS)stretch10.1.26-0+deb9u1vulnerable
stretch (security)10.1.37-0+deb9u1fixed
buster1:10.1.37-1fixed
sid1:10.1.37-3fixed
mysql-5.5 (PTS)jessie5.5.60-0+deb8u1vulnerable
jessie (security)5.5.62-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.24-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)low
mariadb-10.0sourcejessie10.0.35-0+deb8u1lowDLA-1407-1
mariadb-10.1source(unstable)1:10.1.34-1low
mariadb-10.1sourcestretch10.1.37-0+deb9u1lowDSA-4341-1
mariadb-10.2source(unstable)(unfixed)low
mysql-5.5source(unstable)(unfixed)low
mysql-5.5sourcejessie5.5.62-0+deb8u1lowDLA-1566-1
mysql-5.7source(unstable)5.7.23-1low904121

Notes

[wheezy] - mysql-5.5 <postponed> (Wait for next upstream security/bugfix release)
http://www.openwall.com/lists/oss-security/2018/04/08/2
Result from an incomplete fix for CVE-2015-3152 and related CVE for
Oracle products.
For MariaDB: if one connects to the remote server using the embedded library
(libmysqld), then SSL is not enforced.
Fixed in MariaDB: 5.5.60, 10.0.35, 10.1.33, 10.2.15, and 10.3.7
https://github.com/MariaDB/server/commit/f5369faf5bbf
For Oracle: https://github.com/mysql/mysql-server/commit/bbc2e37fe4e
fixed in 5.5.61, 5.6.41, 5.7.23
Strictly speaking though the CVE would be only for Oracle MySQL, for practical
reasons still tracking as well MariaDB here.

Search for package or bug name: Reporting problems