CVE-2018-2787

NameCVE-2018-2787
DescriptionVulnerability in the MySQL Server component of Oracle MySQL (subcomponent: InnoDB). Supported versions that are affected are 5.6.39 and prior and 5.7.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server as well as unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.0 Base Score 5.5 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1407-1
NVD severitymedium (attack range: remote)
Debian Bugs895997, 898445

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.32-0+deb8u1vulnerable
jessie (security)10.0.35-0+deb8u1fixed
mariadb-10.1 (PTS)stretch (security), stretch10.1.26-0+deb9u1vulnerable
buster, sid1:10.1.35-1fixed
mysql-5.5 (PTS)jessie (security), jessie5.5.60-0+deb8u1fixed
mysql-5.7 (PTS)sid5.7.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(unfixed)medium
mariadb-10.0sourcejessie10.0.35-0+deb8u1mediumDLA-1407-1
mariadb-10.1source(unstable)1:10.1.34-1medium898445
mysql-5.5source(unstable)(not affected)
mysql-5.7source(unstable)5.7.22-1medium895997

Notes

- mysql-5.5 <not-affected> (Only affects MySQL 5.6 and 5.7)
Fixed in MariaDB 10.0.35, 10.1.33
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html#AppendixMSQL

Search for package or bug name: Reporting problems