CVE-2018-4181

NameCVE-2018-4181
DescriptionIn macOS High Sierra before 10.13.5, an issue existed in CUPS. This issue was addressed with improved access restrictions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1426-1, DSA-4243-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)jessie1.7.5-11+deb8u2vulnerable
jessie (security)1.7.5-11+deb8u4fixed
stretch2.2.1-8+deb9u3fixed
stretch (security)2.2.1-8+deb9u2fixed
buster, sid2.2.10-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)2.2.8-2medium
cupssourcejessie1.7.5-11+deb8u4mediumDLA-1426-1
cupssourcestretch2.2.1-8+deb9u2mediumDSA-4243-1

Notes

Fixed by: https://github.com/apple/cups/commit/d47f6aec436e0e9df6554436e391471097686ecc

Search for package or bug name: Reporting problems