CVE-2018-5187

NameCVE-2018-5187
DescriptionMemory safety bugs present in Firefox 60 and Firefox ESR 60. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 60, Firefox ESR < 60.1, and Firefox < 61.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1575-1, DSA-4295-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid63.0.3-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1vulnerable
jessie (security)1:60.3.0-1~deb8u1fixed
stretch1:60.2.1-2~deb9u1fixed
stretch (security)1:60.3.0-1~deb9u1fixed
buster, sid1:60.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)61.0-1high
thunderbirdsource(unstable)1:60.0-1high
thunderbirdsourcejessie1:60.3.0-1~deb8u1highDLA-1575-1
thunderbirdsourcestretch1:60.0-3~deb9u1highDSA-4295-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2018-15/#CVE-2018-5187
https://www.mozilla.org/en-US/security/advisories/mfsa2018-19/#CVE-2018-5187

Search for package or bug name: Reporting problems