CVE-2018-5207

NameCVE-2018-5207
DescriptionWhen using an incomplete variable argument, Irssi before 1.0.6 may access data beyond the end of the string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4162-1
NVD severitymedium (attack range: remote)
Debian Bugs886475

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)jessie (security), jessie0.8.17-1+deb8u5vulnerable
stretch1.0.2-1+deb9u3vulnerable
stretch (security)1.0.7-1~deb9u1fixed
buster, sid1.0.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)1.0.7-1medium886475
irssisourcestretch1.0.7-1~deb9u1mediumDSA-4162-1

Notes

[jessie] - irssi <ignored> (Minor issue)
[wheezy] - irssi <no-dsa> (Minor issue)
https://irssi.org/security/irssi_sa_2018_01.txt
https://github.com/irssi/irssi/releases/download/1.0.6/irssi-1.0.5_1.0.6.diff

Search for package or bug name: Reporting problems