DescriptionIn Irssi before 1.0.6, a calculation error in the completion code could cause a heap buffer overflow when completing certain strings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs886475

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)wheezy0.8.15-5vulnerable
wheezy (security)0.8.15-5+deb7u5vulnerable
jessie (security), jessie0.8.17-1+deb8u5vulnerable
stretch (security), stretch1.0.2-1+deb9u3vulnerable
buster, sid1.0.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[stretch] - irssi <no-dsa> (Minor issue)
[jessie] - irssi <no-dsa> (Minor issue)
[wheezy] - irssi <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems