CVE-2018-5800

NameCVE-2018-5800
DescriptionAn off-by-one error within the "LibRaw::kodak_ycbcr_load_raw()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.7 can be exploited to cause a heap-based buffer overflow and subsequently cause a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1734-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)jessie0.16.0-9+deb8u3vulnerable
jessie (security)0.16.0-9+deb8u4fixed
stretch (security), stretch0.17.2-6+deb9u1vulnerable
buster, sid0.19.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.7-1medium
librawsourcejessie0.16.0-9+deb8u4mediumDLA-1734-1

Notes

[stretch] - libraw <no-dsa> (Minor issue)
[wheezy] - libraw <ignored> (Minor issue)
https://packetstormsecurity.com/files/146172/secunia-libraw.txt
https://github.com/LibRaw/LibRaw/commit/8682ad204392b914ab1cc6ebcca9c27c19c1a4b4

Search for package or bug name: Reporting problems