CVE-2018-5805

NameCVE-2018-5805
DescriptionA boundary error within the "quicktake_100_load_raw()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.8 can be exploited to cause a stack-based buffer overflow and subsequently cause a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)jessie0.16.0-9+deb8u3vulnerable
jessie (security)0.16.0-9+deb8u4vulnerable
stretch (security), stretch0.17.2-6+deb9u1vulnerable
buster, sid0.19.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.8-1low

Notes

[stretch] - libraw <no-dsa> (Minor issue)
[jessie] - libraw <no-dsa> (Minor issue)
https://secuniaresearch.flexerasoftware.com/secunia_research/2018-03

Search for package or bug name: Reporting problems