CVE-2018-5808

NameCVE-2018-5808
DescriptionAn error within the "find_green()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.9 can be exploited to cause a stack-based buffer overflow and subsequently execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)jessie (security), jessie0.16.0-9+deb8u3vulnerable
stretch (security), stretch0.17.2-6+deb9u1vulnerable
buster, sid0.19.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.11-1medium

Notes

[stretch] - libraw <no-dsa> (Minor issue)
[jessie] - libraw <ignored> (Minor issue)
https://secuniaresearch.flexerasoftware.com/secunia_research/2018-9/
https://github.com/LibRaw/LibRaw/commit/fd6330292501983ac75fe4162275794b18445bd9

Search for package or bug name: Reporting problems