CVE-2018-5810

NameCVE-2018-5810
DescriptionAn error within the "rollei_load_raw()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.9 can be exploited to cause a heap-based buffer overflow and subsequently cause a crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1734-1, DLA-2903-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)buster0.19.2-2fixed
buster (security)0.19.2-2+deb10u4fixed
bullseye (security), bullseye0.20.2-1+deb11u1fixed
bookworm0.20.2-2.1fixed
trixie0.21.2-2fixed
sid0.21.2-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsourcejessie0.16.0-9+deb8u4DLA-1734-1
librawsourcestretch0.17.2-6+deb9u2DLA-2903-1
librawsource(unstable)0.18.11-1

Notes

[jessie] - libraw <no-dsa> (Minor issue)
https://secuniaresearch.flexerasoftware.com/secunia_research/2018-10/
https://github.com/LibRaw/LibRaw/commit/fd6330292501983ac75fe4162275794b18445bd9

Search for package or bug name: Reporting problems