CVE-2018-5968

NameCVE-2018-5968
DescriptionFasterXML jackson-databind through 2.8.11 and 2.9.x through 2.9.3 allows unauthenticated remote code execution because of an incomplete fix for the CVE-2017-7525 and CVE-2017-17485 deserialization flaws. This is exploitable via two different gadgets that bypass a blacklist.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4114-1
NVD severitymedium (attack range: remote)
Debian Bugs888316

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)jessie (security), jessie2.4.2-2+deb8u4fixed
stretch (security), stretch2.8.6-1+deb9u4fixed
buster, sid2.9.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsource(unstable)2.9.4-1medium888316
jackson-databindsourcejessie2.4.2-2+deb8u3mediumDSA-4114-1
jackson-databindsourcestretch2.8.6-1+deb9u3mediumDSA-4114-1

Notes

https://github.com/FasterXML/jackson-databind/issues/1899
https://github.com/FasterXML/jackson-databind/commit/038b471e2efde2e8f96b4e0be958d3e5a1ff1d05

Search for package or bug name: Reporting problems