CVE-2018-6360

NameCVE-2018-6360
Descriptionmpv through 0.28.0 allows remote attackers to execute arbitrary code via a crafted web site, because it reads HTML documents containing VIDEO elements, and accepts arbitrary URLs in a src attribute without a protocol whitelist in player/lua/ytdl_hook.lua. For example, an av://lavfi:ladspa=file= URL signifies that the product should call dlopen on a shared object file located at an arbitrary local pathname. The issue exists because the product does not consider that youtube-dl can provide a potentially unsafe URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4105-1
NVD severitymedium (attack range: remote)
Debian Bugs888654

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mpv (PTS)jessie0.6.2-2fixed
stretch0.23.0-2vulnerable
stretch (security)0.23.0-2+deb9u2fixed
buster, sid0.27.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mpvsource(unstable)0.27.0-3medium888654
mpvsourcejessie(not affected)
mpvsourcestretch0.23.0-2+deb9u1mediumDSA-4105-1

Notes

[jessie] - mpv <not-affected> (Vulnerable code not present, youtube-dl hook script added in 0.7.0)
https://github.com/mpv-player/mpv/issues/5456
https://github.com/mpv-player/mpv/commit/e6e6b0dcc7e9b0dbf35154a179b3dc1fcfcaff43

Search for package or bug name: Reporting problems