CVE-2018-6553

NameCVE-2018-6553
DescriptionThe CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1426-1, DSA-4243-1
NVD severitymedium (attack range: local)
Debian Bugs903605

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)jessie1.7.5-11+deb8u2vulnerable
jessie (security)1.7.5-11+deb8u4fixed
stretch (security), stretch2.2.1-8+deb9u2fixed
buster2.2.8-5fixed
sid2.2.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)2.2.8-5medium903605
cupssourcejessie1.7.5-11+deb8u4mediumDLA-1426-1
cupssourcestretch2.2.1-8+deb9u2mediumDSA-4243-1

Search for package or bug name: Reporting problems