CVE-2018-6621

NameCVE-2018-6621
DescriptionThe decode_frame function in libavcodec/utvideodec.c in FFmpeg through 3.4.1 allows remote attackers to cause a denial of service (out of array read) via a crafted AVI file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.9-1~deb9u1vulnerable
stretch (security)7:3.2.10-1~deb9u1vulnerable
buster, sid7:3.4.2-1fixed
libav (PTS)wheezy6:0.8.17-2undetermined
wheezy (security)6:0.8.21-0+deb7u1undetermined
jessie6:11.11-1~deb8u1undetermined
jessie (security)6:11.12-1~deb8u1undetermined

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:3.4.2-1low
libavsource(unstable)undetermined

Notes

[stretch] - ffmpeg <postponed> (Wait for next 3.2.x release)
https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/118e1b0b3370dd1c0da442901b486689efd1654b

Search for package or bug name: Reporting problems