CVE-2018-6789

NameCVE-2018-6789
DescriptionAn issue was discovered in the base64d function in the SMTP listener in Exim before 4.90.1. By sending a handcrafted message, a buffer overflow may happen. This can be used to execute code remotely.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1274-1, DSA-4110-1
NVD severityhigh (attack range: remote)
Debian Bugs890000

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)jessie (security), jessie4.84.2-2+deb8u5fixed
stretch (security), stretch4.89-2+deb9u3fixed
buster, sid4.91-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.90.1-1high890000
exim4sourcejessie4.84.2-2+deb8u5highDSA-4110-1
exim4sourcestretch4.89-2+deb9u3highDSA-4110-1
exim4sourcewheezy4.80-7+deb7u6highDLA-1274-1

Notes

http://www.openwall.com/lists/oss-security/2018/02/07/2
https://exim.org/static/doc/security/CVE-2018-6789.txt
https://bugs.exim.org/show_bug.cgi?id=2235
https://git.exim.org/exim.git/commit/062990cc1b2f9e5d82a413b53c8f0569075de700

Search for package or bug name: Reporting problems