CVE-2018-6829

NameCVE-2018-6829
Descriptioncipher/elgamal.c in Libgcrypt through 1.8.2, when used to encrypt messages directly, improperly encodes plaintexts, which allows attackers to obtain sensitive information by reading ciphertext data (i.e., it does not have semantic security in face of a ciphertext-only attack). The Decisional Diffie-Hellman (DDH) assumption does not hold for Libgcrypt's ElGamal implementation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnupg1 (PTS)stretch (security), stretch1.4.21-4+deb9u1vulnerable
buster1.4.23-1vulnerable
bookworm, sid, bullseye1.4.23-1.1vulnerable
libgcrypt20 (PTS)stretch1.7.6-2+deb9u3vulnerable
stretch (security)1.7.6-2+deb9u4vulnerable
buster1.8.4-5+deb10u1vulnerable
bullseye1.8.7-6vulnerable
bookworm, sid1.9.4-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnupgsource(unstable)(unfixed)unimportant
gnupg1source(unstable)(unfixed)unimportant
libgcrypt11source(unstable)(unfixed)unimportant
libgcrypt20source(unstable)(unfixed)unimportant

Notes

https://github.com/weikengchen/attack-on-libgcrypt-elgamal
https://github.com/weikengchen/attack-on-libgcrypt-elgamal/wiki
https://lists.gnupg.org/pipermail/gcrypt-devel/2018-February/004394.html
GnuPG uses ElGamal in hybrid mode only.
This is not a vulnerability in libgcrypt, but in an application using
it in an insecure manner, see also
https://lists.gnupg.org/pipermail/gcrypt-devel/2018-February/004401.html

Search for package or bug name: Reporting problems