CVE-2018-6913

NameCVE-2018-6913
DescriptionHeap-based buffer overflow in the pack function in Perl before 5.26.2 allows context-dependent attackers to execute arbitrary code via a large item count.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1345-1, DSA-4172-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)wheezy5.14.2-21+deb7u3vulnerable
wheezy (security)5.14.2-21+deb7u6fixed
jessie5.20.2-3+deb8u9vulnerable
jessie (security)5.20.2-3+deb8u10fixed
stretch5.24.1-3+deb9u2vulnerable
stretch (security)5.24.1-3+deb9u3fixed
buster5.26.1-6fixed
sid5.26.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.26.1-6
perlsourcejessie5.20.2-3+deb8u10DSA-4172-1
perlsourcestretch5.24.1-3+deb9u3DSA-4172-1
perlsourcewheezy5.14.2-21+deb7u6DLA-1345-1

Notes

https://rt.perl.org/Public/Bug/Display.html?id=131844
maint-5.26: https://perl5.git.perl.org/perl.git/commitdiff/0fcf83230df5f8c52602ae22fde57c7ea885534d
maint-5.24: https://perl5.git.perl.org/perl.git/commitdiff/a9d5c6e11891b48be06d4e06eeed18642bc98527

Search for package or bug name: Reporting problems