CVE-2018-7053

NameCVE-2018-7053
DescriptionAn issue was discovered in Irssi before 1.0.7 and 1.1.x before 1.1.1. There is a use-after-free when SASL messages are received in an unexpected order.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4162-1
NVD severityhigh (attack range: remote)
Debian Bugs890674

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)jessie (security), jessie0.8.17-1+deb8u5fixed
stretch (security), stretch1.0.7-1~deb9u1fixed
buster, sid1.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)1.0.7-1high890674
irssisourcejessie(not affected)
irssisourcestretch1.0.7-1~deb9u1highDSA-4162-1
irssisourcewheezy(not affected)

Notes

[jessie] - irssi <not-affected> (Vulnerable code introduced in 0.8.18)
[wheezy] - irssi <not-affected> (Vulnerable code introduced in 0.8.18)
https://irssi.org/security/irssi_sa_2018_02.txt
Fixed by: https://github.com/irssi/irssi/commit/84f03e01467b90a4251987b32b2813ee976b357c

Search for package or bug name: Reporting problems