CVE-2018-7183

NameCVE-2018-7183
DescriptionBuffer overflow in the decodearr function in ntpq in ntp 4.2.8p6 through 4.2.8p10 allows remote attackers to execute arbitrary code by leveraging an ntpq query and sending a response with a crafted array.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)jessie, jessie (security)1:4.2.6.p5+dfsg-7+deb8u2vulnerable
stretch1:4.2.8p10+dfsg-3+deb9u2vulnerable
buster, sid1:4.2.8p12+dfsg-3fixed
ntpsec (PTS)buster1.1.2+dfsg1-4fixed
sid1.1.2+dfsg1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.8p11+dfsg-1low
ntpsecsource(unstable)(not affected)

Notes

[stretch] - ntp <no-dsa> (Minor issue)
[jessie] - ntp <no-dsa> (Minor issue)
[wheezy] - ntp <no-dsa> (Minor issue)
- ntpsec <not-affected> (Issue not present)
http://www.kb.cert.org/vuls/id/961909
http://support.ntp.org/bin/view/Main/NtpBug3414
http://support.ntp.org/bin/view/Main/SecurityNotice#February_2018_ntp_4_2_8p11_NTP_S

Search for package or bug name: Reporting problems