CVE-2018-7409

NameCVE-2018-7409
DescriptionIn unixODBC before 2.3.5, there is a buffer overflow in the unicode_to_ansi_copy() function in DriverManager/__info.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs891596

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unixodbc (PTS)jessie2.3.1-3vulnerable
stretch2.3.4-1vulnerable
buster, sid2.3.6-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unixodbcsource(unstable)2.3.6-0.1high891596

Notes

[stretch] - unixodbc <no-dsa> (Minor issue)
[jessie] - unixodbc <no-dsa> (Minor issue)
[wheezy] - unixodbc <ignored> (Minor issue)
Fixed by: https://sourceforge.net/p/unixodbc/code/136/
https://github.com/lurcher/unixODBC/commit/4f9f77fb4204659ec9b7be8745d9e05a539c80b9

Search for package or bug name: Reporting problems