CVE-2018-7437

NameCVE-2018-7437
DescriptionAn issue was discovered in FreeXL before 1.0.5. There is a heap-based buffer over-read in a memcpy call of the parse_SST function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1297-1, DSA-4129-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freexl (PTS)jessie (security), jessie1.0.0g-1+deb8u5fixed
stretch (security), stretch1.0.2-2+deb9u2fixed
buster, sid1.0.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freexlsource(unstable)1.0.5-1medium
freexlsourcejessie1.0.0g-1+deb8u5mediumDSA-4129-1
freexlsourcestretch1.0.2-2+deb9u2mediumDSA-4129-1
freexlsourcewheezy1.0.0b-1+deb7u5mediumDLA-1297-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1547885

Search for package or bug name: Reporting problems