CVE-2018-7557

NameCVE-2018-7557
DescriptionThe decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4249-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.10-1~deb9u1vulnerable
stretch (security)7:3.2.12-1~deb9u1fixed
buster7:4.0.2-1fixed
sid7:4.0.2-2fixed
libav (PTS)jessie (security), jessie6:11.12-1~deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:3.4.3-1medium
ffmpegsourcestretch7:3.2.11-1~deb9u1mediumDSA-4249-1
libavsource(unstable)(unfixed)medium

Notes

https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/7414d0bda7763f9bd69c26c068e482ab297c1c96
Fixed in 3.2.11

Search for package or bug name: Reporting problems