CVE-2018-9989

NameCVE-2018-9989
DescriptionARM mbed TLS before 2.1.11, before 2.7.2, and before 2.8.0 has a buffer over-read in ssl_parse_server_psk_hint() that could cause a crash on invalid input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1518-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u3vulnerable
buster2.13.0-3fixed
sid2.14.1-2fixed
polarssl (PTS)jessie1.3.9-2.1+deb8u3vulnerable
jessie (security)1.3.9-2.1+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)2.8.0-1medium
polarsslsource(unstable)(unfixed)medium
polarsslsourcejessie1.3.9-2.1+deb8u4mediumDLA-1518-1

Notes

[stretch] - mbedtls <no-dsa> (Minor issue)
[wheezy] - polarssl <no-dsa> (Minor issue)
https://github.com/ARMmbed/mbedtls/commit/5224a7544c95552553e2e6be0b4a789956a6464e
https://github.com/ARMmbed/mbedtls/commit/740b218386083dc708ce98ccc94a63a95cd5629e
https://tls.mbed.org/tech-updates/releases/mbedtls-2.8.0-2.7.2-and-2.1.11-released

Search for package or bug name: Reporting problems