CVE-2019-1010142

NameCVE-2019-1010142
Descriptionscapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack vector is: over the network or in a pcap. both work.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
scapy (PTS)jessie2.2.0-1fixed
stretch2.3.3-1vulnerable
buster2.4.0-2vulnerable
bullseye, sid2.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
scapysource(unstable)2.4.2-1medium
scapysourcejessie(not affected)

Notes

[jessie] - scapy <not-affected> (Vulnerable code not present)
https://github.com/secdev/scapy/pull/1409
https://github.com/secdev/scapy/commit/0d7ae2b039f650a40e511d09eb961c782da025d9 (v2.4.1)
https://github.com/secdev/scapy/pull/1409/files#diff-441eff981e466959968111fc6314fe93L1058

Search for package or bug name: Reporting problems