CVE-2019-1010182

NameCVE-2019-1010182
Descriptionyaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-yaml-rust (PTS)buster0.4.2-1fixed
bullseye0.4.3-1fixed
bookworm, sid0.4.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-yaml-rustsource(unstable)(not affected)

Notes

- rust-yaml-rust <not-affected> (Fixed before initial release to Debian)
https://github.com/chyh1990/yaml-rust/pull/109

Search for package or bug name: Reporting problems