CVE-2019-10161

NameCVE-2019-10161
DescriptionIt was discovered that libvirtd before versions 4.10.1 and 5.4.1 would permit read-only clients to use the virDomainSaveImageGetXMLDesc() API, specifying an arbitrary path which would be accessed with the permissions of the libvirtd process. An attacker with access to the libvirtd socket could use this to probe the existence of arbitrary files, cause denial of service or cause libvirtd to execute arbitrary programs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1832-1, DSA-4469-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)jessie1.2.9-9+deb8u5vulnerable
jessie (security)1.2.9-9+deb8u7fixed
stretch3.0.0-4+deb9u3vulnerable
stretch (security)3.0.0-4+deb9u4fixed
buster5.0.0-4fixed
bullseye, sid5.0.0-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)5.0.0-4high
libvirtsourcejessie1.2.9-9+deb8u7highDLA-1832-1
libvirtsourcestretch3.0.0-4+deb9u4highDSA-4469-1

Notes

https://access.redhat.com/libvirt-privesc-vulnerabilities
https://bugzilla.redhat.com/show_bug.cgi?id=1720115
https://libvirt.org/git/?p=libvirt.git;a=commit;h=aed6a032cead4386472afb24b16196579e239580

Search for package or bug name: Reporting problems