CVE-2019-1020001

NameCVE-2019-1020001
Descriptionyard before 0.9.20 allows path traversal.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs945369

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yard (PTS)jessie0.8.7.4-1fixed
stretch0.9.7-1vulnerable
buster0.9.16-1vulnerable
bullseye, sid0.9.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yardsource(unstable)0.9.20-1low945369
yardsourcejessie(not affected)

Notes

[buster] - yard <no-dsa> (Minor issue)
[stretch] - yard <no-dsa> (Minor issue)
[jessie] - yard <not-affected> (Bug was introduced in 0.9.6)
https://github.com/lsegal/yard/security/advisories/GHSA-xfhh-rx56-rxcr
Introduced in: https://github.com/lsegal/yard/commit/b32a2efe40e7bd8e5daac7fae119493376a73cde (0.9.6)

Search for package or bug name: Reporting problems