CVE-2019-10241

NameCVE-2019-10241
DescriptionIn Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote client USES a specially formatted URL against the DefaultServlet or ResourceHandler that is configured for showing a Listing of directory contents.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2661-1, DSA-4949-1
NVD severitymedium
Debian Bugs928444

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)stretch9.2.21-1+deb9u1vulnerable
stretch (security)9.2.30-0+deb9u2fixed
buster9.4.15-1vulnerable
buster (security)9.4.16-0+deb10u1fixed
bookworm, sid, bullseye9.4.39-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jettysourcejessie(not affected)
jettysource(unstable)(unfixed)
jetty8source(unstable)(unfixed)
jetty9sourceexperimental9.4.18-1
jetty9sourcestretch9.2.30-0+deb9u1DLA-2661-1
jetty9sourcebuster9.4.16-0+deb10u1DSA-4949-1
jetty9source(unstable)9.4.18-2928444

Notes

[jessie] - jetty8 <no-dsa> (Minor issue)
[jessie] - jetty <not-affected> (Test case reproducers properly HTML-escaped)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=546121
https://github.com/eclipse/jetty.project/issues/3319#issuecomment-567918620

Search for package or bug name: Reporting problems