CVE-2019-10246

NameCVE-2019-10246
DescriptionIn Eclipse Jetty version 9.2.27, 9.3.26, and 9.4.16, the server running on Windows is vulnerable to exposure of the fully qualified Base Resource directory name on Windows to a remote client when it is configured for showing a Listing of directory contents. This information reveal is restricted to only the content in the configured base resource directories.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)stretch9.2.21-1+deb9u1fixed
stretch (security)9.2.30-0+deb9u2fixed
buster, buster (security)9.4.16-0+deb10u1fixed
bookworm, bullseye9.4.39-3fixed
sid9.4.44-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jettysource(unstable)(not affected)
jetty8source(unstable)(not affected)
jetty9source(unstable)(not affected)

Notes

- jetty9 <not-affected> (Only affects Jetty on Windows)
- jetty8 <not-affected> (Only affects Jetty on Windows)
- jetty <not-affected> (Only affects Jetty on Windows)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=546576
https://github.com/eclipse/jetty.project/issues/3549

Search for package or bug name: Reporting problems