CVE-2019-10746

NameCVE-2019-10746
Descriptionprototype pollution
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs932500

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-mixin-deep (PTS)stretch1.1.3-1vulnerable
buster1.1.3-3vulnerable
bullseye, sid2.0.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-mixin-deepsource(unstable)2.0.1-1932500

Notes

[buster] - node-mixin-deep <no-dsa> (Minor issue; will be fixed via point release)
[stretch] - node-mixin-deep <ignored> (Nodejs in stretch not covered by security support)
https://snyk.io/vuln/SNYK-JS-MIXINDEEP-450212
https://github.com/jonschlinkert/mixin-deep/commit/8f464c8ce9761a8c9c2b3457eaeee9d404fa7af9
https://github.com/jonschlinkert/mixin-deep/issues/6

Search for package or bug name: Reporting problems