CVE-2019-10910

NameCVE-2019-10910
DescriptionIn Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1778-1, DSA-4441-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)jessie7.32-1+deb8u12fixed
jessie (security)7.32-1+deb8u17fixed
stretch (security), stretch7.52-2+deb9u9fixed
symfony (PTS)jessie2.3.21+dfsg-4+deb8u3vulnerable
jessie (security)2.3.21+dfsg-4+deb8u5fixed
stretch (security), stretch2.8.7+dfsg-1.3+deb9u2fixed
bullseye, buster3.4.22+dfsg-2fixed
sid4.3.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7source(unstable)(not affected)
symfonysource(unstable)3.4.22+dfsg-2high
symfonysourcejessie2.3.21+dfsg-4+deb8u5highDLA-1778-1
symfonysourcestretch2.8.7+dfsg-1.3+deb9u2highDSA-4441-1

Notes

- drupal7 <not-affected> (Drupal 7 core not affected)
https://www.drupal.org/SA-CORE-2019-005
https://symfony.com/blog/cve-2019-10910-check-service-ids-are-valid

Search for package or bug name: Reporting problems