CVE-2019-10912

NameCVE-2019-10912
DescriptionIn Symfony before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, it is possible to cache objects that may contain bad user input. On serialization or unserialization, this could result in the deletion of files that the current user has access to. This is related to symfony/cache and symfony/phpunit-bridge.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4441-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
symfony (PTS)jessie2.3.21+dfsg-4+deb8u3fixed
jessie (security)2.3.21+dfsg-4+deb8u5fixed
stretch2.8.7+dfsg-1.3+deb9u1vulnerable
stretch (security)2.8.7+dfsg-1.3+deb9u2fixed
bullseye, buster3.4.22+dfsg-2fixed
sid4.3.3+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
symfonysource(unstable)3.4.22+dfsg-2medium
symfonysourcejessie(not affected)
symfonysourcestretch2.8.7+dfsg-1.3+deb9u2mediumDSA-4441-1

Notes

[jessie] - symfony <not-affected> (vulnerable code is not present)
https://symfony.com/blog/cve-2019-10912-prevent-destructors-with-side-effects-from-being-unserialized

Search for package or bug name: Reporting problems