CVE-2019-10913

NameCVE-2019-10913
DescriptionIn Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1778-1, DSA-4441-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
symfony (PTS)jessie2.3.21+dfsg-4+deb8u3vulnerable
jessie (security)2.3.21+dfsg-4+deb8u6fixed
stretch2.8.7+dfsg-1.3+deb9u2fixed
stretch (security)2.8.7+dfsg-1.3+deb9u3fixed
buster3.4.22+dfsg-2fixed
buster (security)3.4.22+dfsg-2+deb10u1fixed
bullseye, sid4.3.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
symfonysource(unstable)3.4.22+dfsg-2
symfonysourcejessie2.3.21+dfsg-4+deb8u5DLA-1778-1
symfonysourcestretch2.8.7+dfsg-1.3+deb9u2DSA-4441-1

Notes

https://symfony.com/blog/cve-2019-10913-reject-invalid-http-method-overrides

Search for package or bug name: Reporting problems