CVE-2019-11050

NameCVE-2019-11050
DescriptionWhen PHP EXIF extension is parsing EXIF information from an image, e.g. via exif_read_data() function, in PHP versions 7.2.x below 7.2.26, 7.3.x below 7.3.13 and 7.4.0 it is possible to supply it with data what will cause it to read past the allocated buffer. This may lead to information disclosure or crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2050-1, DSA-4626-1, DSA-4628-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch (security), stretch7.0.33-0+deb9u8fixed
php7.3 (PTS)buster, buster (security)7.3.19-1~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcejessie5.6.40+dfsg-0+deb8u8DLA-2050-1
php5source(unstable)(unfixed)
php7.0sourcestretch7.0.33-0+deb9u7DSA-4628-1
php7.0source(unstable)(unfixed)
php7.3sourcebuster7.3.14-1~deb10u1DSA-4626-1
php7.3source(unstable)7.3.15-1

Notes

Fixed in PHP 7.4.1, 7.3.13
PHP Bug: http://bugs.php.net/78793

Search for package or bug name: Reporting problems