CVE-2019-11555

NameCVE-2019-11555
DescriptionThe EAP-pwd implementation in hostapd (EAP server) before 2.8 and wpa_supplicant (EAP peer) before 2.8 does not validate fragmentation reassembly state properly for a case where an unexpected fragment could be received. This could result in process termination due to a NULL pointer dereference (denial of service). This affects eap_server/eap_server_pwd.c and eap_peer/eap_pwd.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1867-1, DSA-4450-1
NVD severitymedium (attack range: remote)
Debian Bugs927463

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie2.3-1+deb8u5vulnerable
jessie (security)2.3-1+deb8u8fixed
stretch2:2.4-1+deb9u3vulnerable
stretch (security)2:2.4-1+deb9u4fixed
buster2:2.7+git20190128+0c1e29f-6fixed
bullseye, sid2:2.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasource(unstable)2:2.7+git20190128+0c1e29f-5medium927463
wpasourcejessie2.3-1+deb8u8mediumDLA-1867-1
wpasourcestretch2:2.4-1+deb9u4mediumDSA-4450-1

Notes

https://w1.fi/security/2019-5/eap-pwd-message-reassembly-issue-with-unexpected-fragment.txt
Patches: https://w1.fi/security/2019-5/

Search for package or bug name: Reporting problems