CVE-2019-11597

NameCVE-2019-11597
DescriptionIn ImageMagick 7.0.8-43 Q16, there is a heap-based buffer over-read in the function WriteTIFFImage of coders/tiff.c, which allows an attacker to cause a denial of service or possibly information disclosure via a crafted image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1785-1, DLA-2333-1, DSA-4712-1
NVD severitymedium
Debian Bugs928207

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)stretch8:6.9.7.4+dfsg-11+deb9u8vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u13fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bookworm, sid, bullseye8:6.9.11.60+dfsg-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcejessie8:6.8.9.9-5+deb8u16DLA-1785-1
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u9DLA-2333-1
imagemagicksourcebuster8:6.9.10.23+dfsg-2.1+deb10u1DSA-4712-1
imagemagicksource(unstable)8:6.9.11.24+dfsg-1928207

Notes

https://github.com/ImageMagick/ImageMagick/issues/1555
https://github.com/ImageMagick/ImageMagick6/commit/1d6c036f0388d7857c725342f7212b60e39a14c1
https://github.com/ImageMagick/ImageMagick6/commit/c979b348d64a25a04f12ea7fe7888b2b23f230a7
fix appears to be insufficient: https://github.com/ImageMagick/ImageMagick/issues/1560
https://github.com/ImageMagick/ImageMagick6/commit/3c53413eb544cc567309b4c86485eae43e956112
The followup-fix got assigned CVE-2019-15141 (which is only applicable if incomplete
fix is applied). Make sure to fix issue completely when addressing this issue.

Search for package or bug name: Reporting problems