CVE-2019-11707

NameCVE-2019-11707
DescriptionA type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1829-1, DLA-1836-1, DSA-4466-1, DSA-4471-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid68.0.2-3fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1vulnerable
jessie (security)60.8.0esr-1~deb8u1fixed
stretch60.6.1esr-1~deb9u1vulnerable
stretch (security)60.8.0esr-1~deb9u1fixed
buster60.7.2esr-1fixed
buster (security)60.8.0esr-1~deb10u1fixed
bullseye60.8.0esr-1fixed
sid68.0.2esr-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1vulnerable
jessie (security)1:60.8.0-1~deb8u1fixed
stretch1:60.6.1-1~deb9u1vulnerable
stretch (security)1:60.8.0-1~deb9u1fixed
buster1:60.7.2-1fixed
buster (security)1:60.8.0-1~deb10u1fixed
bullseye1:60.8.0-1fixed
sid1:60.8.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)67.0.3-1high
firefox-esrsource(unstable)60.7.1esr-1high
firefox-esrsourcejessie60.7.1esr-1~deb8u1highDLA-1829-1
firefox-esrsourcestretch60.7.1esr-1~deb9u1highDSA-4466-1
thunderbirdsource(unstable)1:60.7.2-1high
thunderbirdsourcejessie1:60.7.2-1~deb8u1highDLA-1836-1
thunderbirdsourcestretch1:60.7.2-1~deb9u1highDSA-4471-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-18/#CVE-2019-11707
https://www.mozilla.org/en-US/security/advisories/mfsa2019-20/#CVE-2019-11707

Search for package or bug name: Reporting problems