CVE-2019-11745

NameCVE-2019-11745
DescriptionOut-of-bounds write when passing an output buffer smaller than the block size to NSC_EncryptUpdate
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2008-1, DSA-4579-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)jessie2:3.26-1+debu8u3vulnerable
jessie (security)2:3.26-1+debu8u9fixed
stretch (security), stretch2:3.26.2-1.1+deb9u1vulnerable
buster2:3.42.1-1+deb10u1vulnerable
buster (security)2:3.42.1-1+deb10u2fixed
bullseye2:3.45-1vulnerable
sid2:3.47.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsssource(unstable)2:3.47.1-1
nsssourcebuster2:3.42.1-1+deb10u2DSA-4579-1
nsssourcejessie2:3.26-1+debu8u7DLA-2008-1

Notes

https://bugzilla.mozilla.org/show_bug.cgi?id=1586176 (not public)
https://hg.mozilla.org/projects/nss/rev/1e22a0c93afe9f46545560c86caedef9dab6cfda
Fixed in 3.44.3 and 3.47.1 upstream.

Search for package or bug name: Reporting problems