DescriptionA race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzstd (PTS)stretch1.1.2-1fixed
stretch (security)1.1.2-1+deb9u1fixed
buster, buster (security)1.3.8+dfsg-3+deb10u2fixed
bookworm, sid, bullseye1.4.8+dfsg-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzstdsourcestretch(not affected)


[stretch] - libzstd <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems