CVE-2019-11922

NameCVE-2019-11922
DescriptionA race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzstd (PTS)stretch1.1.2-1fixed
bullseye, buster1.3.8+dfsg-3fixed
sid1.4.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzstdsource(unstable)1.3.8+dfsg-2medium
libzstdsourcestretch(not affected)

Notes

[stretch] - libzstd <not-affected> (Vulnerable code not present)
https://github.com/facebook/zstd/commit/3e5cdf1b6a85843e991d7d10f6a2567c15580da0

Search for package or bug name: Reporting problems