CVE-2019-12219

NameCVE-2019-12219
DescriptionAn issue was discovered in libSDL2.a in Simple DirectMedia Layer (SDL) 2.0.9 when used in conjunction with libSDL2_image.a in SDL2_image 2.0.4. There is an invalid free error in the SDL function SDL_SetError_REAL at SDL_error.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1861-1, DLA-1865-1
NVD severitymedium
Debian Bugs932754, 932755

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsdl2-image (PTS)jessie2.0.0+dfsg-3+deb8u1vulnerable
jessie (security)2.0.0+dfsg-3+deb8u2fixed
stretch2.0.1+dfsg-2+deb9u2fixed
stretch (security)2.0.1+dfsg-2+deb9u1vulnerable
buster2.0.4+dfsg1-1+deb10u1fixed
bullseye, sid2.0.5+dfsg1-1fixed
sdl-image1.2 (PTS)jessie1.2.12-5+deb8u1vulnerable
jessie (security)1.2.12-5+deb8u2fixed
stretch1.2.12-5+deb9u2fixed
stretch (security)1.2.12-5+deb9u1vulnerable
buster1.2.12-10+deb10u1fixed
bullseye, sid1.2.12-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsdl2-imagesource(unstable)2.0.5+dfsg1-1932754
libsdl2-imagesourcebuster2.0.4+dfsg1-1+deb10u1
libsdl2-imagesourcejessie2.0.0+dfsg-3+deb8u2DLA-1861-1
libsdl2-imagesourcestretch2.0.1+dfsg-2+deb9u2
sdl-image1.2source(unstable)1.2.12-11932755
sdl-image1.2sourcebuster1.2.12-10+deb10u1
sdl-image1.2sourcejessie1.2.12-5+deb8u2DLA-1865-1
sdl-image1.2sourcestretch1.2.12-5+deb9u2

Notes

https://bugzilla.libsdl.org/show_bug.cgi?id=4625
https://hg.libsdl.org/SDL_image/rev/e7e9786a1a34

Search for package or bug name: Reporting problems