CVE-2019-12386

NameCVE-2019-12386
DescriptionAn issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1988-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ampache (PTS)jessie3.6-rzb2752+dfsg-5vulnerable
jessie (security)3.6-rzb2752+dfsg-5+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ampachesource(unstable)(unfixed)
ampachesourcejessie3.6-rzb2752+dfsg-5+deb8u1DLA-1988-1

Notes

https://github.com/ampache/ampache/issues/1872
according to the github issue, it is not really fixed yet

Search for package or bug name: Reporting problems