CVE-2019-12420

NameCVE-2019-12420
DescriptionIn Apache SpamAssassin before 3.4.3, a message can be crafted in a way to use excessive resources. Upgrading to SA 3.4.3 as soon as possible is the recommended fix but details will not be shared publicly.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2037-1, DSA-4584-1
NVD severitymedium
Debian Bugs946653

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spamassassin (PTS)jessie3.4.0-6vulnerable
jessie (security)3.4.2-0+deb8u2fixed
stretch3.4.2-1~deb9u1vulnerable
stretch (security)3.4.2-1~deb9u2fixed
buster3.4.2-1vulnerable
buster (security)3.4.2-1+deb10u1fixed
bullseye, sid3.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spamassassinsource(unstable)3.4.3~rc6-1946653
spamassassinsourcebuster3.4.2-1+deb10u1DSA-4584-1
spamassassinsourcejessie3.4.2-0+deb8u2DLA-2037-1
spamassassinsourcestretch3.4.2-1~deb9u2DSA-4584-1

Notes

https://www.openwall.com/lists/oss-security/2019/12/12/2
https://markmail.org/message/pyp425yrulfxyhrn
https://svn.apache.org/r1866128

Search for package or bug name: Reporting problems