CVE-2019-12447

NameCVE-2019-12447
DescriptionAn issue was discovered in GNOME gvfs 1.29.4 through 1.41.2. daemon/gvfsbackendadmin.c mishandles file ownership because setfsuid is not used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs929755

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gvfs (PTS)jessie1.22.2-1fixed
jessie (security)1.22.2-1+deb8u1fixed
stretch1.30.4-1vulnerable
buster1.38.1-5fixed
bullseye, sid1.42.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gvfssource(unstable)1.38.1-4medium929755
gvfssourcejessie(not affected)

Notes

[stretch] - gvfs <no-dsa> (Minor issue)
[jessie] - gvfs <not-affected> (Vulnerable code introduced later)
https://gitlab.gnome.org/GNOME/gvfs/commit/daf1163aba229afcfddf0f925aef7e97047e8959
https://gitlab.gnome.org/GNOME/gvfs/commit/3895e09d784ebec0fbc4614d5c37068736120e1d

Search for package or bug name: Reporting problems