CVE-2019-12448

NameCVE-2019-12448
DescriptionAn issue was discovered in GNOME gvfs 1.29.4 through 1.41.2. daemon/gvfsbackendadmin.c has race conditions because the admin backend doesn't implement query_info_on_read/write.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs929755

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gvfs (PTS)jessie1.22.2-1fixed
jessie (security)1.22.2-1+deb8u1fixed
stretch1.30.4-1vulnerable
bullseye, sid, buster1.38.1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gvfssource(unstable)1.38.1-4medium929755
gvfssourcejessie(not affected)

Notes

[jessie] - gvfs <not-affected> (Vulnerable code introduced later)
https://gitlab.gnome.org/GNOME/gvfs/commit/5cd76d627f4d1982b6e77a0e271ef9301732d09e

Search for package or bug name: Reporting problems