CVE-2019-12585

NameCVE-2019-12585
DescriptionApcupsd 0.3.91_5, as used in pfSense through 2.4.4-RELEASE-p3 and other products, has an Arbitrary Command Execution issue in apcupsd_status.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apcupsd (PTS)buster3.14.14-2fixed
bookworm, sid, bullseye3.14.14-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apcupsdsource(unstable)(not affected)

Notes

- apcupsd <not-affected> (Vulnerable code in pfSense-specific status page)

Search for package or bug name: Reporting problems