CVE-2019-12760

NameCVE-2019-12760
Description** DISPUTED ** A deserialization vulnerability exists in the way parso through 0.4.0 handles grammar parsing from the cache. Cache loading relies on pickle and, provided that an evil pickle can be written to a cache grammar file and that its parsing can be triggered, this flaw leads to Arbitrary Code Execution. NOTE: This is disputed because "the cache directory is not under control of the attacker in any common configuration."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs930356

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
parso (PTS)buster0.3.1-1vulnerable
bullseye, sid0.5.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
parsosource(unstable)0.5.1-0.1unimportant930356

Notes

https://gist.github.com/dhondta/f71ae7e5c4234f8edfd2f12503a5dcc7
https://github.com/davidhalter/parso/issues/75
Not considered a security issue by upstream

Search for package or bug name: Reporting problems