CVE-2019-12838

NameCVE-2019-12838
DescriptionSchedMD Slurm 17.11.x, 18.08.0 through 18.08.7, and 19.05.0 allows SQL Injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs931880

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)jessie14.03.9-5+deb8u2vulnerable
jessie (security)14.03.9-5+deb8u4vulnerable
stretch (security), stretch16.05.9-1+deb9u2vulnerable
buster18.08.5.2-1vulnerable
sid18.08.6.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)(unfixed)high931880

Notes

https://lists.schedmd.com/pipermail/slurm-announce/2019/000025.html

Search for package or bug name: Reporting problems